summaryrefslogtreecommitdiffstats
path: root/Model01-Firmware.ino
Commit message (Collapse)AuthorAgeFilesLines
...
* Make the sketch use backslash lessCsilla Nagyné Martinák2017-10-041-36/+36
| | | | | | | This lass is not fond of backslash, so she made the sketch use backslash less, so much so that it is now backslash-less. Signed-off-by: Csilla Nagyné Martinák <csilla@csillger.hu>
* Fix misleading indentation in all three layers' keymapsCraig Disselkoen2017-10-031-3/+10
| | | | plus add astyle directives to make astyle not complain about it
* update to shifttolayer and instead of the old keymap_n_momentary macros;Jesse Vincent2017-10-031-9/+15
| | | | update doc
* Remove the NULL from the end of Kaleidoscope.useCsilla Nagyné Martinák2017-10-031-2/+2
| | | | | | | | For a while now, `Kaleidoscope.use` does not require a NULL sentinel at the end. This drops the sentinel instead of adding documentation that would explain why that NULL is there. Signed-off-by: Csilla Nagyné Martinák <csilla@csillger.hu>
* clean up indentation of keymapsJesse Vincent2017-10-021-46/+45
|
* remove the special NUMPAD_ID definition; move the keymap definitions into ↵Jesse Vincent2017-10-021-72/+60
| | | | | | the variable declaration. This has the advantage of having one fewer construct to explain
* Doc updates as suggested by @cdisselkoen++Jesse Vincent2017-10-021-6/+7
|
* Slightly simplify the default keymaps, removing some duplicationJesse Vincent2017-10-021-5/+5
|
* Close a commentJesse Vincent2017-10-021-1/+1
|
* astyleJesse Vincent2017-10-021-35/+35
|
* First pass at comments on the rest of the default sketchJesse Vincent2017-10-021-16/+54
|
* comment much of the default sketchJesse Vincent2017-10-021-3/+140
|
* We're not actually exposing BootKeyboard yet.Jesse Vincent2017-10-021-1/+0
|
* Move some LED color definitions to after the macro defnitions.Jesse Vincent2017-10-021-8/+14
| | | | It seems a little clearer.
* move the hopefully-going-away numpad keymap id definition closer toJesse Vincent2017-10-021-1/+1
| | | | where one can intuit why it's that number
* reorganize imports for a little more clarityJesse Vincent2017-10-021-2/+5
|
* whitespaceJesse Vincent2017-10-021-1/+1
|
* Refactor macro code to remove hand-coded numbers and make code a bit more ↵Jesse Vincent2017-10-021-14/+32
| | | | readable
* astyleJesse Vincent2017-10-021-2/+2
|
* Remove a couple of C preprocessor macros involved in the definition ofJesse Vincent2017-10-021-4/+3
| | | | keyboard macros, in the hope of making the code clearer
* DEBUG_SERIAL is unused. kill itJesse Vincent2017-10-021-2/+0
|
* replace a magic seeming constant with a macroJesse Vincent2017-10-021-1/+1
|
* decompose a conditional to make it easier to read and refactorJesse Vincent2017-10-021-3/+5
|
* Kaleidoscope.setup no longer takes an argumentJesse Vincent2017-10-021-1/+1
|
* change the name of a compiler macro to make it clear that it's an idJesse Vincent2017-10-021-2/+2
|
* rename our keymaps to be more consistent.Jesse Vincent2017-10-021-6/+6
| | | | | | I feel weird about putting the name before the word 'keymap', but this seems less confusing than explaining why KEYMAP_QWERTY and KEYMAP_STACKED are different kidns of entitites
* Updated to use the new NumLock pluginGergely Nagy2017-10-011-4/+2
| | | | | | | The NumLock plugin works without a macro now, so we can simplify the factory firmware by just using `Key_KeypadNumLock`. Signed-off-by: Gergely Nagy <kaleidoscope@gergo.csillger.hu>
* Updated to use the new LEDMode/LEDControl APIsGergely Nagy2017-08-161-7/+7
| | | | Signed-off-by: Gergely Nagy <kaleidoscope@gergo.csillger.hu>
* astyleJesse Vincent2017-08-131-12/+12
|
* We had the wrong key definition for what keyboards actually use as theJesse Vincent2017-08-131-1/+1
| | | | 'menu'
* First pass at adding in the boot greeting plugin to make the LED keyJesse Vincent2017-08-131-2/+4
| | | | glow on boot
* Switch our mute key to Key_Mute in the hope that it works better on OSXJesse Vincent2017-08-071-1/+1
|
* Turn the Fn keys into Keymap1_MomentaryGergely Nagy2017-07-301-2/+2
| | | | | | | | | | | | | | | When both `Fn` keys are `KeymapNext_Momentary`, holding both would get us to the `NUMPAD` layer, which overrides the palm keys and turns them into `Keymap1_Momentary` keys. Thus, when releasing them, we would receive a release event for `Keymap1_Momentary`, not for `KeymapNext_Momentary`, and we'd be stuck on the `Numpad` layer until toggling it off. To avoid this scenario, change the `KeymapNext_Momentary` keys into `Keymap1_Momentary`, so we never reach the `NUMPAD` layer via the `Fn` keys. Fixes keyboardio/Kaleidoscope#151, with thanks to @chughes87 for the report! Signed-off-by: Gergely Nagy <algernon@madhouse-project.org>
* astyleJesse Vincent2017-07-251-2/+2
|
* Fix key repeat on Any. Port to new hid facade apiJesse Vincent2017-07-251-3/+7
|
* switch to new CamelCased' toggle functionsJesse Vincent2017-07-241-3/+3
|
* Update to work with an argument-less NumLock.toggle()Gergely Nagy2017-07-021-1/+2
| | | | Signed-off-by: Gergely Nagy <algernon@madhouse-project.org>
* move the rainbow effects earlier in the effect listJesse Vincent2017-06-191-1/+2
|
* brighten up the rainbow effectsJesse Vincent2017-06-121-0/+2
|
* Move the version key to "any" on the numlock layerJesse Vincent2017-06-121-2/+2
|
* Macro.type needs PSTR() macros around strings.Jesse Vincent2017-06-111-4/+3
| | | | Algernon talked me out of putting the newline in the macro
* That's a stacked keymapJesse Vincent2017-06-101-1/+1
|
* Update the versioning macro to hopefully pull verison info in from the build ↵Jesse Vincent2017-06-091-9/+11
| | | | system
* Call Macros "Macro_blah" rather than "Key_blah"Jesse Vincent2017-06-091-2/+2
|
* Update mouse buttons to match the printed layout cardsJesse Vincent2017-06-071-3/+3
|
* formatting cleanupJesse Vincent2017-06-071-17/+17
|
* Remove tabsJesse Vincent2017-06-071-35/+35
|
* Update to new Stalker APIJesse Vincent2017-06-071-1/+1
|
* "make astyle"Jesse Vincent2017-06-071-43/+43
|
* Cut down the example key layoutsJesse Vincent2017-05-221-64/+41
|