summaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
...
| * Fix trailing slashakihito.nakano2017-10-221-1/+1
|/
* Merge pull request #24 from malsyned/patch-1Gergely Nagy2017-10-191-1/+1
|\ | | | | Fix link to Linux Arduino install instructions
| * Fix link to Linux Arduino install instructionsDennis Lambe Jr2017-10-191-1/+1
|/
* Merge pull request #20 from Jennigma/patch-1Jesse Vincent2017-10-131-0/+1
|\ | | | | Adding a pointer to the wiki
| * Adding a pointer to the wikiJennifer Leigh2017-10-131-0/+1
|/ | | put it up front where it would be super obvious.
* Fix our arduino-ide package detection to work on OSXJesse Vincent2017-10-041-8/+10
|
* makefile: if there's an arduino boards-manager install of the kaleidoscope ↵Jesse Vincent2017-10-041-0/+11
| | | | runtime, use it..
* Merge pull request #18 from Jennigma/patch-1Jesse Vincent2017-10-041-0/+2
|\ | | | | Added a couple "to be documented" items
| * Added a couple "to be documented" itemsJennifer Leigh2017-10-041-0/+2
|/ | | | | | | I added a couple items to the list of things that should be documented. I also realize I have no idea what the ANY key does, but I'm intrigued. I don't understand from these code comments, and don't have time to puzzle it out now. Otherwise, though, this is so much better than the file I've been poking at for weeks! It's clear and clean and much more welcoming. Thanks for all the behind the scenes work that made this possible, and thank you Jesse for the work writing up comments!
* Merge pull request #17 from martinakcsilla/backslashlessJesse Vincent2017-10-041-36/+36
|\ | | | | Make the sketch use backslash less
| * Make the sketch use backslash lessCsilla Nagyné Martinák2017-10-041-36/+36
|/ | | | | | | This lass is not fond of backslash, so she made the sketch use backslash less, so much so that it is now backslash-less. Signed-off-by: Csilla Nagyné Martinák <csilla@csillger.hu>
* Merge pull request #16 from cdisselkoen/masterJesse Vincent2017-10-031-3/+10
|\ | | | | Fix misleading indentation in all three layers' keymaps
| * Fix misleading indentation in all three layers' keymapsCraig Disselkoen2017-10-031-3/+10
|/ | | | plus add astyle directives to make astyle not complain about it
* Little bits of glue to make the Model01 Firwmare into a 'real' arduino ↵Jesse Vincent2017-10-032-0/+10
| | | | library that the IDE doesn't hate
* update to shifttolayer and instead of the old keymap_n_momentary macros;Jesse Vincent2017-10-031-9/+15
| | | | update doc
* Merge pull request #15 from martinakcsilla/use-does-not-need-sentinelJesse Vincent2017-10-031-2/+2
|\ | | | | Remove the NULL from the end of Kaleidoscope.use
| * Remove the NULL from the end of Kaleidoscope.useCsilla Nagyné Martinák2017-10-031-2/+2
|/ | | | | | | | For a while now, `Kaleidoscope.use` does not require a NULL sentinel at the end. This drops the sentinel instead of adding documentation that would explain why that NULL is there. Signed-off-by: Csilla Nagyné Martinák <csilla@csillger.hu>
* clean up indentation of keymapsJesse Vincent2017-10-021-46/+45
|
* remove the special NUMPAD_ID definition; move the keymap definitions into ↵Jesse Vincent2017-10-021-72/+60
| | | | | | the variable declaration. This has the advantage of having one fewer construct to explain
* Doc updates as suggested by @cdisselkoen++Jesse Vincent2017-10-021-6/+7
|
* add notes about updating firmware and libraries to the READMEJesse Vincent2017-10-021-2/+27
|
* Slightly simplify the default keymaps, removing some duplicationJesse Vincent2017-10-021-5/+5
|
* Close a commentJesse Vincent2017-10-021-1/+1
|
* astyleJesse Vincent2017-10-021-35/+35
|
* First pass at comments on the rest of the default sketchJesse Vincent2017-10-021-16/+54
|
* comment much of the default sketchJesse Vincent2017-10-021-3/+140
|
* We're not actually exposing BootKeyboard yet.Jesse Vincent2017-10-021-1/+0
|
* Move some LED color definitions to after the macro defnitions.Jesse Vincent2017-10-021-8/+14
| | | | It seems a little clearer.
* move the hopefully-going-away numpad keymap id definition closer toJesse Vincent2017-10-021-1/+1
| | | | where one can intuit why it's that number
* reorganize imports for a little more clarityJesse Vincent2017-10-021-2/+5
|
* whitespaceJesse Vincent2017-10-021-1/+1
|
* Refactor macro code to remove hand-coded numbers and make code a bit more ↵Jesse Vincent2017-10-021-14/+32
| | | | readable
* astyleJesse Vincent2017-10-021-2/+2
|
* Remove a couple of C preprocessor macros involved in the definition ofJesse Vincent2017-10-021-4/+3
| | | | keyboard macros, in the hope of making the code clearer
* DEBUG_SERIAL is unused. kill itJesse Vincent2017-10-021-2/+0
|
* replace a magic seeming constant with a macroJesse Vincent2017-10-021-1/+1
|
* decompose a conditional to make it easier to read and refactorJesse Vincent2017-10-021-3/+5
|
* Kaleidoscope.setup no longer takes an argumentJesse Vincent2017-10-021-1/+1
|
* change the name of a compiler macro to make it clear that it's an idJesse Vincent2017-10-021-2/+2
|
* rename our keymaps to be more consistent.Jesse Vincent2017-10-021-6/+6
| | | | | | I feel weird about putting the name before the word 'keymap', but this seems less confusing than explaining why KEYMAP_QWERTY and KEYMAP_STACKED are different kidns of entitites
* Merge pull request #14 from algernon/f/numlock-no-macroJesse Vincent2017-10-021-4/+2
|\ | | | | Updated to use the new NumLock plugin.
| * Updated to use the new NumLock pluginGergely Nagy2017-10-011-4/+2
| | | | | | | | | | | | | | The NumLock plugin works without a macro now, so we can simplify the factory firmware by just using `Key_KeypadNumLock`. Signed-off-by: Gergely Nagy <kaleidoscope@gergo.csillger.hu>
* | add some notes to the end of the readme. Thanks to @Jennigma++Jesse Vincent2017-10-021-0/+10
|/
* A couple explanatory notes suggested by Jennifer LeighJesse Vincent2017-09-081-2/+5
|
* Merge pull request #13 from cdisselkoen/improved-flashing-docsGergely Nagy2017-08-271-1/+8
|\ | | | | Improve documentation related to flashing
| * Improve documentation related to flashingCraig Disselkoen2017-08-241-1/+8
|/ | | | In particular, add instructions for the Arduino IDE
* Point Makefile to new make rulesJesse Vincent2017-08-211-1/+1
|
* Merge pull request #12 from algernon/f/led-api-updateGergely Nagy2017-08-171-7/+7
|\ | | | | Updated to use the new LEDMode/LEDControl APIs
| * Updated to use the new LEDMode/LEDControl APIsGergely Nagy2017-08-161-7/+7
| | | | | | | | Signed-off-by: Gergely Nagy <kaleidoscope@gergo.csillger.hu>
* | add a note about customizing the location of the Arduino install on LinuxJesse Vincent2017-08-161-2/+5
| |